summaryrefslogtreecommitdiffstats
path: root/target/mips/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 4a951e522d..3b131c4a7f 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -3,6 +3,7 @@ gen = [
decodetree.process('mips64r6.decode', extra_args: '--static-decode=decode_mips64r6'),
decodetree.process('msa32.decode', extra_args: '--static-decode=decode_msa32'),
decodetree.process('msa64.decode', extra_args: '--static-decode=decode_msa64'),
+ decodetree.process('tx79.decode', extra_args: '--static-decode=decode_tx79'),
]
mips_ss = ss.source_set()
@@ -23,6 +24,10 @@ mips_tcg_ss.add(files(
'tlb_helper.c',
'translate.c',
'translate_addr_const.c',
+ 'txx9_translate.c',
+))
+mips_ss.add(when: ['CONFIG_TCG', 'TARGET_MIPS64'], if_true: files(
+ 'tx79_translate.c',
))
mips_tcg_ss.add(when: 'TARGET_MIPS64', if_false: files(
'mxu_translate.c',