summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2015-12-17 14:20:12 +0100
committerSimon Rettberg2015-12-17 14:20:12 +0100
commit3de54fac10b3dbdcfc3573e175078c7104837ef3 (patch)
tree307abe2cc283900c0ce0594c7d40d833d8b27c92 /CMakeLists.txt
parent[SERVER] Cancel scanning of image dir if _shutdown is set (diff)
downloaddnbd3-3de54fac10b3dbdcfc3573e175078c7104837ef3.tar.gz
dnbd3-3de54fac10b3dbdcfc3573e175078c7104837ef3.tar.xz
dnbd3-3de54fac10b3dbdcfc3573e175078c7104837ef3.zip
[SERVER] image_markComplete now handles locking so we remove() unlocked
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf85392..628e36e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ if(CMAKE_C_COMPILER MATCHES "clang")
SET(CMAKE_C_FLAGS_RELEASE "-std=c99 -O2 -Wno-unused-result -D_GNU_SOURCE -DNDEBUG -Wno-multichar -fno-strict-aliasing")
elseif (CMAKE_C_COMPILER MATCHES "(cc-)|(cc$)")
message( "Using (g)cc flags." )
- SET(CMAKE_C_FLAGS_DEBUG "-std=c99 -O0 -g -Wall -Wextra -Wpedantic -D_GNU_SOURCE -D_DEBUG -Wno-multichar -fno-strict-aliasing")
+ SET(CMAKE_C_FLAGS_DEBUG "-std=c99 -O0 -pg -g -Wall -Wextra -Wpedantic -D_GNU_SOURCE -D_DEBUG -Wno-multichar -fno-strict-aliasing")
SET(CMAKE_C_FLAGS_RELEASE "-std=c99 -O2 -Wno-unused-result -D_GNU_SOURCE -DNDEBUG -Wno-multichar -fno-strict-aliasing")
else()
message( FATAL_ERROR "Could not determine compiler type." )