summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2015-01-14 13:55:34 +0100
committerSimon Rettberg2015-01-14 13:55:34 +0100
commitf9b94dcafa867c38dfaeb9b24f37b392d1ad80d8 (patch)
tree9343235020bbdd8a70b4096c54da58c3dfe757ac /CMakeLists.txt
parent[SERVER] Fix stupid bug (not using errno) (diff)
downloaddnbd3-f9b94dcafa867c38dfaeb9b24f37b392d1ad80d8.tar.gz
dnbd3-f9b94dcafa867c38dfaeb9b24f37b392d1ad80d8.tar.xz
dnbd3-f9b94dcafa867c38dfaeb9b24f37b392d1ad80d8.zip
[SERVER] Crank up warning levels of gcc and fix them all (mostly sign compare and some unused params)
Also allow newline at end of alt-servers file without complaining about it not being a valid alt server definition.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d81a842..e0425ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ if(CMAKE_C_COMPILER MATCHES "clang")
SET(CMAKE_C_FLAGS_RELEASE "-std=c99 -O2 -Wno-unused-result -D_GNU_SOURCE -DNDEBUG -Wno-multichar")
elseif (CMAKE_C_COMPILER MATCHES "(cc-)|(cc$)")
message( "Using (g)cc flags." )
- SET(CMAKE_C_FLAGS_DEBUG "-std=c99 -O0 -g -pedantic -Wall -Wno-unused-result -D_GNU_SOURCE -D_DEBUG -Wno-multichar")
+ SET(CMAKE_C_FLAGS_DEBUG "-std=c99 -O0 -g -pedantic -Wall -Wextra -D_GNU_SOURCE -D_DEBUG -Wno-multichar")
SET(CMAKE_C_FLAGS_RELEASE "-std=c99 -O2 -Wno-unused-result -D_GNU_SOURCE -DNDEBUG -Wno-multichar")
else()
message( FATAL_ERROR "Could not determine compiler type." )