summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 1e1567669..157b5e913 100644
--- a/Makefile
+++ b/Makefile
@@ -516,6 +516,12 @@ help:
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
+release: distclean
+ OUT=buildroot-$$(grep -A2 BR2_VERSION $(CONFIG_CONFIG_IN)|grep default|cut -f2 -d\"); \
+ rm -rf ../$$OUT*; cp -al . ../$$OUT; cd ..; \
+ tar cfz $$OUT.tar.gz --exclude .svn --exclude .git --exclude \*~ $$OUT; \
+ rm -rf $$OUT
+
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend defconfig help