summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ea338fc5c..aabecc1f6 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -159,6 +159,7 @@ TARGETS+=linux26
endif
# Checks to give errors that the user can understand
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
$(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
@@ -169,4 +170,6 @@ ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)),)
$(error No kernel configuration file specified, check your BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE setting)
endif
-endif \ No newline at end of file
+endif
+
+endif