summaryrefslogtreecommitdiffstats
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 53cc8eba0..5987d3823 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -439,6 +439,12 @@ ifndef $(2)_SITE_METHOD
endif
endif
+ifeq ($$($(2)_SITE_METHOD),local)
+ifeq ($$($(2)_OVERRIDE_SRCDIR),)
+$(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
+endif
+endif
+
$(2)_DEPENDENCIES ?=
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO