summaryrefslogtreecommitdiffstats
path: root/package/libdrm
diff options
context:
space:
mode:
Diffstat (limited to 'package/libdrm')
-rw-r--r--package/libdrm/Config.in1
-rw-r--r--package/libdrm/libdrm.mk13
2 files changed, 12 insertions, 2 deletions
diff --git a/package/libdrm/Config.in b/package/libdrm/Config.in
index 445eb72e1..ab8c2d883 100644
--- a/package/libdrm/Config.in
+++ b/package/libdrm/Config.in
@@ -7,6 +7,7 @@ config BR2_PACKAGE_LIBDRM
select BR2_PACKAGE_XLIB_LIBXMU
select BR2_PACKAGE_XPROTO_DRI2PROTO
select BR2_PACKAGE_PTHREAD_STUBS
+ select BR2_PACKAGE_LIBATOMIC_OPS if BR2_PACKAGE_XDRIVER_XF86_VIDEO_INTEL
help
Direct Rendering Manager
diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
index 791e67dcf..38cb636fd 100644
--- a/package/libdrm/libdrm.mk
+++ b/package/libdrm/libdrm.mk
@@ -6,11 +6,20 @@
LIBDRM_VERSION = 2.4.19
LIBDRM_SOURCE = libdrm-$(LIBDRM_VERSION).tar.bz2
LIBDRM_SITE = http://dri.freedesktop.org/libdrm/
-LIBDRM_AUTORECONF = NO
LIBDRM_LIBTOOL_PATCH = NO
LIBDRM_INSTALL_STAGING = YES
-LIBDRM_INSTALL_TARGET = YES
LIBDRM_DEPENDENCIES = xproto_glproto xproto_xf86vidmodeproto xlib_libXxf86vm xlib_libXmu xproto_dri2proto pthread-stubs
+ifeq ($(BR2_PACKAGE_XDRIVER_XF86_VIDEO_INTEL),y)
+LIBDRM_CONF_OPT += --enable-intel
+LIBDRM_DEPENDENCIES += libatomic_ops
+else
+LIBDRM_CONF_OPT += --disable-intel
+endif
+
+ifneq ($(BR2_PACKAGE_XDRIVER_XF86_VIDEO_ATI),y)
+LIBDRM_CONF_OPT += --disable-radeon
+endif
+
$(eval $(call AUTOTARGETS,package,libdrm))
class='commitgraph'>| * | f2fs: set SBI_NEED_FSCK for xattr corruption caseChao Yu2019-07-031-0/+6 | * | f2fs: use generic EFSBADCRC/EFSCORRUPTEDChao Yu2019-07-0314-37/+46 | * | f2fs: Use DIV_ROUND_UP() instead of open-codingGeert Uytterhoeven2019-07-033-6/+6 | * | f2fs: print kernel message if filesystem is inconsistentChao Yu2019-07-031-0/+2 | * | f2fs: introduce f2fs_<level> macros to wrap f2fs_printk()Joe Perches2019-07-0314-507/+351Star | * | f2fs: avoid get_valid_blocks() for cleanupChao Yu2019-07-031-4/+2Star | * | f2fs: ioctl for removing a range from F2FSQiuyang Sun2019-07-037-5/+260 | * | f2fs: only set project inherit bit for directoryWang Shilong2019-06-212-1/+3 | * | f2fs: separate f2fs i_flags from fs_flags and ext4 i_flagsEric Biggers2019-06-212-118/+163 | * | f2fs: replace ktype default_attrs with default_groupsKimberly Brown2019-06-211-2/+4 | * | f2fs: Add option to limit required GC for checkpoint=disableDaniel Rosenberg2019-06-034-25/+73 | * | f2fs: Fix accounting for unusable blocksDaniel Rosenberg2019-06-031-5/+10 | * | f2fs: Fix root reserved on remountDaniel Rosenberg2019-06-031-1/+2 | * | f2fs: Lower threshold for disable_cp_againDaniel Rosenberg2019-06-031-3/+5 | * | f2fs: fix sparse warningChao Yu2019-05-302-3/+3 | * | f2fs: fix f2fs_show_options to show nodiscard mount optionSahitya Tummala2019-05-301-0/+2 | * | f2fs: add error prints for debugging mount failureSahitya Tummala2019-05-302-3/+7 | * | f2fs: fix to do sanity check on segment bitmap of LFS cursegChao Yu2019-05-301-0/+39 | * | f2fs: fix to avoid deadloop if data_flush is onChao Yu2019-05-234-0/+9 | * | f2fs: always assume that the device is idle under gc_urgentPark Ju Hyung2019-05-231-0/+3 | * | f2fs: add bio cache for IPUChao Yu2019-05-233-10/+86 | * | f2fs: allow ssr block allocation during checkpoint=disable periodJaegeuk Kim2019-05-231-1/+2 | * | f2fs: fix to check layout on last valid checkpoint parkChao Yu2019-05-232-11/+9Star | * | f2fs: link f2fs quota ops for sysfileJaegeuk Kim2019-05-232-8/+3Star * | | Merge tag 'xfs-5.3-merge-12' of git://git.kernel.org/pub/scm/fs/xfs/xfs-linuxLinus Torvalds2019-07-13