summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/generic/Config.in11
-rw-r--r--target/generic/Makefile.in13
2 files changed, 24 insertions, 0 deletions
diff --git a/target/generic/Config.in b/target/generic/Config.in
index 4969fcdc4..7961beccc 100644
--- a/target/generic/Config.in
+++ b/target/generic/Config.in
@@ -109,6 +109,17 @@ config BR2_TARGET_GENERIC_GETTY_BAUDRATE
default "57600" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
default "115200" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
+config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
+ bool "remount root filesystem read-write during boot"
+ default y
+ help
+ The root filesystem is typically mounted read-only at boot.
+ By default, buildroot remounts it in read-write mode early during the
+ boot process.
+ Say no here if you would rather like your root filesystem to remain
+ read-only.
+ If unsure, say Y.
+
endif # BR2_ROOTFS_SKELETON_DEFAULT
config BR2_ROOTFS_POST_BUILD_SCRIPT
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index ce07ecfd0..4185202b7 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -23,6 +23,14 @@ target-generic-getty-sysvinit:
$(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
$(TARGET_DIR)/etc/inittab
+# Find commented line, if any, and remove leading '#'s
+target-generic-do-remount-rw:
+ $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
+
+# Find uncommented line, if any, and add a leading '#'
+target-generic-dont-remount-rw:
+ $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
+
ifneq ($(TARGET_GENERIC_HOSTNAME),)
TARGETS += target-generic-hostname
endif
@@ -37,4 +45,9 @@ TARGETS += target-generic-getty-sysvinit
else
TARGETS += target-generic-getty-busybox
endif
+ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
+TARGETS += target-generic-do-remount-rw
+else
+TARGETS += target-generic-dont-remount-rw
+endif
endif