summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-09-10 11:17:53 +0200
committerKarel Zak2012-09-10 11:17:53 +0200
commit6cd3e35c777ffdd679087c3063348150300471c0 (patch)
tree0bdd72b42c5e55ad95be51de334321ab9e6afd4e /configure.ac
parentlibmount: improve mnt_table_get_root_fs() docs (diff)
parentFix configure to work with multiarch distributions. (diff)
downloadkernel-qcow2-util-linux-6cd3e35c777ffdd679087c3063348150300471c0.tar.gz
kernel-qcow2-util-linux-6cd3e35c777ffdd679087c3063348150300471c0.tar.xz
kernel-qcow2-util-linux-6cd3e35c777ffdd679087c3063348150300471c0.zip
Merge https://github.com/hramrach/util-linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 24 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5890b8526..b85530909 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,30 @@ case $prefix:$localstatedir in
esac
AC_SUBST([localstatedir])
-libdirname=`basename "$libdir"`
+# sed_quote separator string
+# Prefixes occurences of sed special characters and separator with \ in string.
+# Suggested separators: , / (space) .
+# Note that the character is prefixed with \ so characters that get special meaning
+# will not work as separator. eg: n \ ? ( { ) }
+sed_quote()
+{
+ echo -n "$2" | sed -e 's/\n/\\n/' -e 's|\([][*.$|'"$1"']\)|\\\1|g'
+}
+
+# remove_dir_prefix prefix path
+# Remove leading path prefix.
+# Return directory name without leading slash (basename drop-in).
+# Handle prefix trailing slash.
+# // (double slash) is not handled.
+remove_dir_prefix(){
+ local prefix="$(sed_quote "," "$1")"
+ echo "$1" | grep -q '/$' || prefix="${prefix}/"
+ local re="^$(sed_quote "," "$prefix")"
+ echo "$2" | grep -q "$re" || re=/
+ echo "$2" | sed -e "s,${re},,"
+}
+
+libdirname=`remove_dir_prefix '${exec_prefix}' "$libdir"`
AC_SUBST([libdirname])
# The original default values of {bin,sbin,lib}dir