summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2007-02-08 15:19:36 +0100
committerKarel Zak2007-02-08 15:19:36 +0100
commitdeef0ba55e45e275e4f23bdf93fcd24c0750d8ae (patch)
tree25cfb1c96f9842ee3616c3d33f3b9d314e1850fe /configure.ac
parentbuild-sys: fix README filenames and add missing files to EXTRA_DISTs (diff)
downloadkernel-qcow2-util-linux-deef0ba55e45e275e4f23bdf93fcd24c0750d8ae.tar.gz
kernel-qcow2-util-linux-deef0ba55e45e275e4f23bdf93fcd24c0750d8ae.tar.xz
kernel-qcow2-util-linux-deef0ba55e45e275e4f23bdf93fcd24c0750d8ae.zip
build-sys: configure.am selinux support cleanup
Changes: - don't include SELinux as default (--with-selinux is required) - the SELinux is not useful for login-utils only - clean up PAM and login-utils tests in the configure.am Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index dd7da82cd..ccd05b361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -277,7 +277,7 @@ AM_CONDITIONAL(BUILD_LOGIN_UTILS, test x$enable_login_utils = xyes)
AC_ARG_WITH([pam],
AC_HELP_STRING([--without-pam], [compile login-utils without PAM support]),
- with_pam=$withval, with_pam=not_checked
+ with_pam=$withval, with_pam=yes
)
if test x$enable_login_utils = xyes && test x$with_pam != xno; then
@@ -289,11 +289,11 @@ fi
AM_CONDITIONAL(HAVE_PAM, test x$ac_cv_header_security_pam_misc_h = xyes)
AC_ARG_WITH([selinux],
- AC_HELP_STRING([--without-selinux], [compile login-utils without SELinux support]),
- with_selinux=$withval, with_selinux=not_checked
+ AC_HELP_STRING([--with-selinux], [compile with SELinux support]),
+ with_selinux=$withval, with_selinux=no
)
-if test x$enable_login_utils = xyes && test x$with_selinux != xno; then
+if test x$with_selinux != xno; then
AC_CHECK_LIB(selinux, getprevcon)
if test x$with_selinux = xyes && test x$ac_cv_lib_selinux_getprevcon = xno; then
AC_MSG_ERROR([SELinux selected but libselinux not found])