summaryrefslogtreecommitdiffstats
path: root/fdisk/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2010-05-07 14:12:26 +0200
committerKarel Zak2010-05-07 14:12:26 +0200
commit5f94ca33cf7772e0c36b5b3e5b1cf1ab01f60180 (patch)
treeca7fbaf1bc031a50d958993eb52e29407fc6fdd9 /fdisk/Makefile.am
parenttests: update blkid/md-raid1-* tests (diff)
downloadkernel-qcow2-util-linux-5f94ca33cf7772e0c36b5b3e5b1cf1ab01f60180.tar.gz
kernel-qcow2-util-linux-5f94ca33cf7772e0c36b5b3e5b1cf1ab01f60180.tar.xz
kernel-qcow2-util-linux-5f94ca33cf7772e0c36b5b3e5b1cf1ab01f60180.zip
cfdisk: support non-ascii characters in input
On Sat, Apr 03, 2010 at 12:58:48PM +0000, Jorge wrote: > When you want to write changes to disk you're asked for a > confirmation, like this one: > > Are you sure you want to write the partition table to disk? (yes > or no) > > There is no problem on the English version, but when you launch the > program in Spanish you get this: > > ¿Está seguro de que desea escribir la tabla de particiones en el > disco? > (sí o no): > > You can't type the "í" character. Trying to do so will end in no > input at all. That is, typing in my keyboard "´" then "i" leads to > nothing. So you can't write changes to disk, and you must launch the > program in English for it to operate. Reported-by: Jorge <yo@jorgesuarezdelis.name> Addresses: https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/205327 Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'fdisk/Makefile.am')
-rw-r--r--fdisk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fdisk/Makefile.am b/fdisk/Makefile.am
index 862fa0162..7b87d6cf5 100644
--- a/fdisk/Makefile.am
+++ b/fdisk/Makefile.am
@@ -53,7 +53,7 @@ endif
if USE_SLANG
sbin_PROGRAMS += cfdisk
dist_man_MANS += cfdisk.8
-cfdisk_SOURCES = cfdisk.c $(fdisk_common)
+cfdisk_SOURCES = cfdisk.c $(fdisk_common) ../lib/mbsalign.c
cfdisk_CFLAGS = $(cflags_blkid)
cfdisk_LDADD = -lslang $(ldadd_blkid)
else