summaryrefslogtreecommitdiffstats
path: root/fdisk/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady2010-03-09 09:21:35 +0100
committerKarel Zak2010-03-16 15:29:01 +0100
commitb8d22034f1b393a48ce7af9e15d910bf0e29df0b (patch)
tree9cce7f888f5f7e48dd6c879b2554d152db1b0904 /fdisk/Makefile.am
parentlib: add #ifndef around min() max() macros (diff)
downloadkernel-qcow2-util-linux-b8d22034f1b393a48ce7af9e15d910bf0e29df0b.tar.gz
kernel-qcow2-util-linux-b8d22034f1b393a48ce7af9e15d910bf0e29df0b.tar.xz
kernel-qcow2-util-linux-b8d22034f1b393a48ce7af9e15d910bf0e29df0b.zip
fdisk: correctly truncate and align translated partition names
* fdisk/Makefile.am: Depend on the mbsalign module. * fdisk/fdisk.c: Align using mbsalign rather than printf. [kzak@redhat.com: - use size_t for width to fix gcc warning] Reported-by: Makoto Kato <m_kato@ga2.so-net.ne.jp> Signed-off-by: Pádraig Brady <P@draigBrady.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'fdisk/Makefile.am')
-rw-r--r--fdisk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/fdisk/Makefile.am b/fdisk/Makefile.am
index 50f1dbe85..862fa0162 100644
--- a/fdisk/Makefile.am
+++ b/fdisk/Makefile.am
@@ -3,7 +3,7 @@ include $(top_srcdir)/config/include-Makefile.am
EXTRA_DIST = README.fdisk README.cfdisk sfdisk.examples partitiontype.c
fdisk_common = i386_sys_types.c common.h gpt.c gpt.h \
- ../lib/blkdev.c ../lib/wholedisk.c
+ ../lib/blkdev.c ../lib/wholedisk.c ../lib/mbsalign.c
if LINUX
fdisk_common += ../lib/linux_version.c