summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-03-09 14:56:18 +0100
committerKarel Zak2007-03-09 14:56:18 +0100
commit71562c1fddf8d025b5de94d1df3b89278fc679b2 (patch)
treeac33dd6e1441c543400cdf7a05869251c04eebe6 /login-utils/Makefile.am
parentlogin: update 32bit utmp correctly on 64bit system (diff)
downloadkernel-qcow2-util-linux-71562c1fddf8d025b5de94d1df3b89278fc679b2.tar.gz
kernel-qcow2-util-linux-71562c1fddf8d025b5de94d1df3b89278fc679b2.tar.xz
kernel-qcow2-util-linux-71562c1fddf8d025b5de94d1df3b89278fc679b2.zip
login: add regression test for IP address checking code
The hnmatch() in checktty.c is checking IP addresses if the login util is compiled without PAM support. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index cc894e196..0a36e158f 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -116,3 +116,8 @@ install-exec-hook::
cd $(DESTDIR)$(mandir)/man8 && ln -sf initctl.8 provide.8
endif
+
+noinst_PROGRAMS = checktty_test
+checktty_test_SOURCES = checktty.c login.h
+checktty_test_CFLAGS = -DMAIN_TEST_CHECKTTY
+