summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-08-14 14:32:45 +0200
committerKarel Zak2007-08-14 14:32:45 +0200
commitf3831bbd801135d7e618725cdfd7ff99f52e33a6 (patch)
treec82abe1e7e593297558cce310ed74644f542013f /login-utils/Makefile.am
parentdocs: add README.licensing (diff)
downloadkernel-qcow2-util-linux-f3831bbd801135d7e618725cdfd7ff99f52e33a6.tar.gz
kernel-qcow2-util-linux-f3831bbd801135d7e618725cdfd7ff99f52e33a6.tar.xz
kernel-qcow2-util-linux-f3831bbd801135d7e618725cdfd7ff99f52e33a6.zip
build-sys: add --disable-makeinstall-chown
A chown-like operations are unexpected when you execute "make install" as non-root user. For example RPM defines owner+permissions in .spec file -- you needn't to use root account to create useful RPM package. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index 639db58c6..de45f26fd 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -26,7 +26,7 @@ if NEED_LIBCRYPT
simpleinit_LDADD = -lcrypt
endif
-endif
+endif
if BUILD_LAST
usrbinexec_PROGRAMS += last
@@ -101,17 +101,17 @@ man_MANS += mesg.1
endif
if BUILD_WALL
-
usrbinexec_PROGRAMS += wall
wall_SOURCES = wall.c ttymsg.c ttymsg.h
man_MANS += wall.1
if USE_TTY_GROUP
+if MAKEINSTALL_DO_CHOWN
install-exec-hook::
chgrp tty $(DESTDIR)$(usrbinexecdir)/wall
chmod g+s $(DESTDIR)$(usrbinexecdir)/wall
endif
-
+endif
endif
if BUILD_INIT