summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-03-12 14:26:34 +0100
committerKarel Zak2007-03-12 14:26:34 +0100
commitf8bdba2fd24a176d8d0ef8c96fb184fa3cd0f7bf (patch)
tree2b53b795bd192cc951f18b637e9f19f412961c3a /login-utils/Makefile.am
parentbuild-sys: add support for audit (diff)
downloadkernel-qcow2-util-linux-f8bdba2fd24a176d8d0ef8c96fb184fa3cd0f7bf.tar.gz
kernel-qcow2-util-linux-f8bdba2fd24a176d8d0ef8c96fb184fa3cd0f7bf.tar.xz
kernel-qcow2-util-linux-f8bdba2fd24a176d8d0ef8c96fb184fa3cd0f7bf.zip
login: add audit support
The login command reports AUDIT_USER_LOGIN message to audit system (depends on --with-audit). Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index 0a36e158f..404b7987f 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -67,6 +67,9 @@ else
login_SOURCES = login.c checktty.c login.h my_crypt.h
endif
+if HAVE_AUDIT
+login_LDADD += -laudit
+endif
if HAVE_SELINUX
chfn_SOURCES += selinux_utils.c selinux_utils.h