summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2011-10-05 12:10:26 +0200
committerKarel Zak2011-10-26 23:17:17 +0200
commitc82d9c977c7fdf28ede2db15601edde1a5819511 (patch)
treef8173e4967e03186f3ae1bdbfe85a273006c46f6 /login-utils/Makefile.am
parenttests: cleanup islocal test (diff)
downloadkernel-qcow2-util-linux-c82d9c977c7fdf28ede2db15601edde1a5819511.tar.gz
kernel-qcow2-util-linux-c82d9c977c7fdf28ede2db15601edde1a5819511.tar.xz
kernel-qcow2-util-linux-c82d9c977c7fdf28ede2db15601edde1a5819511.zip
login: add login.defs code and tests
The new logindefs.c file contains /etc/login.defs parser and functions for searching in the list of the login default variables. The patch also contains a new regression test for the code. Based on pam_login-4.0 from Suse. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index a5909a6f5..84036fc2a 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -65,6 +65,9 @@ install-exec-hook::
endif
-noinst_PROGRAMS = test_islocal
+noinst_PROGRAMS = test_islocal test_logindefs
test_islocal_SOURCES = islocal.c
test_islocal_CPPFLAGS = -DTEST_PROGRAM $(AM_CPPFLAGS)
+
+test_logindefs_SOURCES = logindefs.c logindefs.h
+test_logindefs_CPPFLAGS = -DTEST_PROGRAM $(AM_CPPFLAGS)