summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-04-24 11:44:19 +0200
committerKarel Zak2007-04-25 00:20:46 +0200
commit06bcee19a248efe225d744a09a44638c07685bef (patch)
tree868b6fe77db68f6ccc8bb0fa80f1ca4f85946e42 /mount/Makefile.am
parentmount: add support for mtab "uhelper" option (diff)
downloadkernel-qcow2-util-linux-06bcee19a248efe225d744a09a44638c07685bef.tar.gz
kernel-qcow2-util-linux-06bcee19a248efe225d744a09a44638c07685bef.tar.xz
kernel-qcow2-util-linux-06bcee19a248efe225d744a09a44638c07685bef.zip
build-sys: add SUID_CFLAGS
The patch allows to define special CFLAGS for typical suid programs (like mount, umount, chfn, ...). Some distributions use for example "-fpic" for suid binaries. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index f34fc83b9..6f0d403d9 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -22,6 +22,7 @@ mount_SOURCES = mount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c \
$(MNTHDRS)
mount_LDADD = $(top_srcdir)/lib/libenv.a $(top_srcdir)/lib/libsetproctitle.a
+mount_CFLAGS = $(SUID_CFLAGS)
umount_SOURCES = umount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c \
getusername.c get_label_uuid.c mount_by_label.c mount_blkid.c \
@@ -29,6 +30,7 @@ umount_SOURCES = umount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c
$(MNTHDRS)
umount_LDADD = $(top_srcdir)/lib/libenv.a
+umount_CFLAGS = $(SUID_CFLAGS)
swapon_SOURCES = swapon.c xmalloc.c \
get_label_uuid.c mount_by_label.c mount_blkid.c \