summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-03-28 18:43:03 +0200
committerKarel Zak2007-03-28 18:43:03 +0200
commit2cd72ac0e054bb070cad880d0cc9366ebf08b3eb (patch)
tree8e7c3f873dddf4e33dd63008142a6176afc90025 /mount/Makefile.am
parenttests: make clean need to remove diffs and outputs (diff)
downloadkernel-qcow2-util-linux-2cd72ac0e054bb070cad880d0cc9366ebf08b3eb.tar.gz
kernel-qcow2-util-linux-2cd72ac0e054bb070cad880d0cc9366ebf08b3eb.tar.xz
kernel-qcow2-util-linux-2cd72ac0e054bb070cad880d0cc9366ebf08b3eb.zip
tests: add lock_mtab() performance and reliability test
The test starts concurrently many processes that use lock_mtab() as lock for access to same file. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index 605c4520c..f34fc83b9 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -48,6 +48,9 @@ sbin_PROGRAMS += pivot_root
man_MANS += pivot_root.8
endif
+noinst_PROGRAMS = mtab_lock_test
+mtab_lock_test_SOURCES = fstab.c sundries.c xmalloc.c $(MNTHDRS)
+mtab_lock_test_CFLAGS = -DMAIN_TEST_MTABLOCK
swapon.c: swapargs.h