summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorStepan Kasal2007-05-15 20:46:03 +0200
committerKarel Zak2007-05-16 11:43:29 +0200
commit3f3c9c909a41611ac5d2a9c151290296aa30a97f (patch)
treeedecba12e0a74bf4dadf9c7216db0ae8ac9dfec9 /mount/Makefile.am
parentbuild-sys: do not play with DEFS, use AM_CPPFLAGS (diff)
downloadkernel-qcow2-util-linux-3f3c9c909a41611ac5d2a9c151290296aa30a97f.tar.gz
kernel-qcow2-util-linux-3f3c9c909a41611ac5d2a9c151290296aa30a97f.tar.xz
kernel-qcow2-util-linux-3f3c9c909a41611ac5d2a9c151290296aa30a97f.zip
build-sys: add SUID_LDFLAGS
Programs which are usually installed with the setuid bit do need their own CFLAGS and LDFLAGS. SUID_LDFLAGS is analogic to SUID_CFLAGS. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index e52ec6fa9..cf7b00d26 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -20,6 +20,7 @@ mount_SOURCES = mount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c \
mount_LDADD = $(top_srcdir)/lib/libenv.a $(top_srcdir)/lib/libsetproctitle.a
mount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS)
+mount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
umount_SOURCES = umount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c \
getusername.c get_label_uuid.c mount_by_label.c mount_blkid.c \
@@ -28,6 +29,7 @@ umount_SOURCES = umount.c fstab.c sundries.c xmalloc.c realpath.c mount_mntent.c
umount_LDADD = $(top_srcdir)/lib/libenv.a
umount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS)
+umount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
swapon_SOURCES = swapon.c xmalloc.c \
get_label_uuid.c mount_by_label.c mount_blkid.c \