summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-05-14 14:31:28 +0200
committerKarel Zak2007-05-17 12:10:18 +0200
commit65a567e837338052ab0714ee5eab925d74f4a6c1 (patch)
tree454d9a6c8ca8ee7c5ae9a9d4a9085af3f396c8df /mount/Makefile.am
parentmount: fsprobe: rename the rest of API routines to fsprobe_* (diff)
downloadkernel-qcow2-util-linux-65a567e837338052ab0714ee5eab925d74f4a6c1.tar.gz
kernel-qcow2-util-linux-65a567e837338052ab0714ee5eab925d74f4a6c1.tar.xz
kernel-qcow2-util-linux-65a567e837338052ab0714ee5eab925d74f4a6c1.zip
mount: fsprobe: make fsprobe_get_devname functions more generic
The blkid supports NAME=value parsing, but use the library for this simple task is overkill. (The libblkid requires initialized blkid cache all time, for all calls.) This patch makes the fsprobe_get_devname_for_mounting() and fsprobe_get_devname() generic for all fsprobe implementations. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index ae67ed639..fb3301339 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -22,7 +22,7 @@ umount_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS)
umount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
swapon_SOURCES = swapon.c xmalloc.c \
- swap_constants.h realpath.c
+ swap_constants.h realpath.c fsprobe.c sundries.c
losetup_SOURCES = lomount.c loop.h lomount.h
losetup_CPPFLAGS = -DMAIN $(AM_CPPFLAGS)