summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorStepan Kasal2007-12-11 18:47:34 +0100
committerKarel Zak2008-02-18 13:27:02 +0100
commit8569410cf59389890bb3d5cd9109e9431223c561 (patch)
treea093ac7fcf8e10699a5b6bc6ba441090bfb073fc /mount/Makefile.am
parentfdisk: use more readable "GPT" name rather than "EFI GPT" (diff)
downloadkernel-qcow2-util-linux-8569410cf59389890bb3d5cd9109e9431223c561.tar.gz
kernel-qcow2-util-linux-8569410cf59389890bb3d5cd9109e9431223c561.tar.xz
kernel-qcow2-util-linux-8569410cf59389890bb3d5cd9109e9431223c561.zip
build-sys: add --enable-static-programs
Add support for static versions of mount, umount, losetup, fdisk, and sfdisk. Co-Author: Karel Zak <kzak@redhat.com> Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am31
1 files changed, 28 insertions, 3 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index bba596268..a43fcd5dc 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -35,20 +35,45 @@ umount_LDADD = $(LDADD_common)
swapon_LDADD = $(LDADD_common)
LDADD_common =
+LDADD_common_static =
+
+if HAVE_STATIC_MOUNT
+bin_PROGRAMS += mount.static
+mount_static_SOURCES = $(mount_SOURCES)
+mount_static_LDFLAGS = $(LDFLAGS_STATIC)
+mount_static_LDADD = $(LDADD_common_static)
+endif
+
+if HAVE_STATIC_UMOUNT
+bin_PROGRAMS += umount.static
+umount_static_SOURCES = $(umount_SOURCES)
+umount_static_LDFLAGS = $(LDFLAGS_STATIC)
+umount_static_LDADD = $(LDADD_common_static)
+endif
+
+if HAVE_STATIC_LOSETUP
+bin_PROGRAMS += losetup.static
+losetup_static_SOURCES = $(losetup_SOURCES)
+losetup_static_LDFLAGS = $(LDFLAGS_STATIC)
+losetup_static_CPPFLAGS = -DMAIN $(AM_CPPFLAGS)
+endif
if HAVE_BLKID
utils_common += fsprobe_blkid.c
-LDADD_common += -lblkid -luuid
+LDADD_common += $(BLKID_LIBS)
+LDADD_common_static += $(BLKID_LIBS_STATIC)
endif
if HAVE_SELINUX
-mount_LDADD += -lselinux
+mount_LDADD += $(SELINUX_LIBS)
+mount_static_LDADD = $(SELINUX_LIBS_STATIC)
endif
if HAVE_VOLUME_ID
utils_common += fsprobe_volumeid.c
swapon_SOURCES += ../lib/linux_version.c ../lib/blkdev.c
-LDADD_common += -lvolume_id
+LDADD_common += $(VOLUMEID_LIBS)
+LDADD_common_static += $(VOLUMEID_LIBS_STATIC)
endif
if HAVE_PIVOT_ROOT