summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorStepan Kasal2007-05-15 20:46:20 +0200
committerKarel Zak2007-05-16 11:43:30 +0200
commitb34258064dd36e6b22b0ea8bf3ad4365cc078057 (patch)
treed1e77c57c8dd197510dba8fd64ddd1b7522615ad /mount/Makefile.am
parentbuild-sys: replace AC_TRY_* by AC_*_IFELSE (diff)
downloadkernel-qcow2-util-linux-b34258064dd36e6b22b0ea8bf3ad4365cc078057.tar.gz
kernel-qcow2-util-linux-b34258064dd36e6b22b0ea8bf3ad4365cc078057.tar.xz
kernel-qcow2-util-linux-b34258064dd36e6b22b0ea8bf3ad4365cc078057.zip
build-sys: remove swapargs.h, move the tests to main configure.ac
Do not use header swapargs.h, generated by script swap.configure; use the standard AC_DEFINE method in configure.ac. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am10
1 files changed, 1 insertions, 9 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index 18a5c60ee..96ecc3238 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/config/include-Makefile.am
-EXTRA_DIST = README.mount swap.configure
+EXTRA_DIST = README.mount
bin_PROGRAMS = mount umount
sbin_PROGRAMS = losetup swapon
@@ -54,14 +54,6 @@ noinst_PROGRAMS = mtab_lock_test
mtab_lock_test_SOURCES = fstab.c sundries.c xmalloc.c $(MNTHDRS)
mtab_lock_test_CPPFLAGS = -DMAIN_TEST_MTABLOCK $(AM_CPPFLAGS)
-swapon.c: swapargs.h
-
-swapargs.h:
- sh swap.configure
-
-clean-local:
- rm -f swapargs.h
-
install-exec-hook:
chmod 4755 $(DESTDIR)$(bindir)/mount
chmod 4755 $(DESTDIR)$(bindir)/umount