summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2010-03-10 23:59:33 +0100
committerKarel Zak2010-03-10 23:59:33 +0100
commitbf71ef0797c42f4b1754ec8756819c633a0d0d73 (patch)
tree6cc49639c56ad8d1b71fbd0c60a438e5da7bb1c9 /mount/Makefile.am
parentlib: add mangle.c for mtab (fstab or swaps) encoding (diff)
downloadkernel-qcow2-util-linux-bf71ef0797c42f4b1754ec8756819c633a0d0d73.tar.gz
kernel-qcow2-util-linux-bf71ef0797c42f4b1754ec8756819c633a0d0d73.tar.xz
kernel-qcow2-util-linux-bf71ef0797c42f4b1754ec8756819c633a0d0d73.zip
swapon: use unmangle() for filenames from /proc/swaps
linux kernel encodes all garbage in filenames by mangle() function. We need to unmagle() to get the real filenames. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index c5f58aa3f..769403062 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -37,7 +37,8 @@ umount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
umount_LDADD = $(ldadd_common)
swapon_SOURCES = swapon.c swap_constants.h ../lib/linux_version.c \
- ../lib/blkdev.c ../lib/fsprobe.c ../lib/canonicalize.c
+ ../lib/blkdev.c ../lib/fsprobe.c ../lib/canonicalize.c \
+ ../lib/mangle.c
swapon_CFLAGS = $(cflags_common)
swapon_LDADD = $(ldadd_common)