summaryrefslogtreecommitdiffstats
path: root/schedutils/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger2007-08-26 13:22:56 +0200
committerKarel Zak2007-08-27 10:48:29 +0200
commit19a224ad6aaed8b4547b85255d8deae80e8336da (patch)
tree57ea59e53a911c9620299453b023710428ed7b46 /schedutils/Makefile.am
parentsetarch: add parisc/parisc64 support (diff)
downloadkernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.tar.gz
kernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.tar.xz
kernel-qcow2-util-linux-19a224ad6aaed8b4547b85255d8deae80e8336da.zip
taskset: check for existence of sched_getaffinity
Some architectures do no reliably provide sched_getaffinity, so make sure the define exists before we try using it. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'schedutils/Makefile.am')
-rw-r--r--schedutils/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/schedutils/Makefile.am b/schedutils/Makefile.am
index 03e3080b5..e93d31b39 100644
--- a/schedutils/Makefile.am
+++ b/schedutils/Makefile.am
@@ -2,7 +2,12 @@ include $(top_srcdir)/config/include-Makefile.am
if BUILD_SCHEDUTILS
-usrbinexec_PROGRAMS = chrt ionice taskset
-man_MANS = chrt.1 ionice.1 taskset.1
+usrbinexec_PROGRAMS = chrt ionice
+man_MANS = chrt.1 ionice.1
+
+if HAVE_SCHED_GETAFFINITY
+usrbinexec_PROGRAMS += taskset
+man_MANS += taskset.1
+endif
endif