summaryrefslogtreecommitdiffstats
path: root/schedutils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2010-09-30 23:27:42 +0200
committerKarel Zak2010-09-30 23:29:14 +0200
commit24295096586c848a5eb3f8d8b73a73f03c174fc1 (patch)
tree1c071246891d5182753589a334e2ca0cd2d5bad4 /schedutils/Makefile.am
parentfdisk: eliminate redundant call to open() (diff)
downloadkernel-qcow2-util-linux-24295096586c848a5eb3f8d8b73a73f03c174fc1.tar.gz
kernel-qcow2-util-linux-24295096586c848a5eb3f8d8b73a73f03c174fc1.tar.xz
kernel-qcow2-util-linux-24295096586c848a5eb3f8d8b73a73f03c174fc1.zip
taskset: proper numbers parsing
Reported-by: Davidlohr Bueso <dave@gnu.org> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'schedutils/Makefile.am')
-rw-r--r--schedutils/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/schedutils/Makefile.am b/schedutils/Makefile.am
index 13d45c85d..c83e5eaff 100644
--- a/schedutils/Makefile.am
+++ b/schedutils/Makefile.am
@@ -2,19 +2,24 @@ include $(top_srcdir)/config/include-Makefile.am
if BUILD_SCHEDUTILS
+srcs_common = schedutils.c schedutils.h
+
usrbin_exec_PROGRAMS = chrt
dist_man_MANS = chrt.1
+chrt_SOURCES = chrt.c $(srcs_common)
+
if HAVE_IOPRIO_GET
if HAVE_IOPRIO_SET
usrbin_exec_PROGRAMS += ionice
+ionice_SOURCES = ionice.c $(srcs_common)
dist_man_MANS += ionice.1
endif
endif
if HAVE_SCHED_GETAFFINITY
usrbin_exec_PROGRAMS += taskset
-taskset_SOURCES = taskset.c $(top_srcdir)/lib/cpuset.c
+taskset_SOURCES = taskset.c $(top_srcdir)/lib/cpuset.c $(srcs_common)
dist_man_MANS += taskset.1
endif