summaryrefslogtreecommitdiffstats
path: root/schedutils/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger2007-09-07 16:55:36 +0200
committerKarel Zak2007-09-20 00:22:22 +0200
commit72065909ccd29cd3c7c3105c95ba2434db304552 (patch)
tree0e8705d5cfc36f60fd9d2500b1c9023ed098c5a0 /schedutils/Makefile.am
parentbuild-sys: nls/locale handling in util-linux-ng general (diff)
downloadkernel-qcow2-util-linux-72065909ccd29cd3c7c3105c95ba2434db304552.tar.gz
kernel-qcow2-util-linux-72065909ccd29cd3c7c3105c95ba2434db304552.tar.xz
kernel-qcow2-util-linux-72065909ccd29cd3c7c3105c95ba2434db304552.zip
build-sys: unify method for checking system calls and fallback handling
Co-Author: Stepan Kasal <skasal@redhat.com> Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'schedutils/Makefile.am')
-rw-r--r--schedutils/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/schedutils/Makefile.am b/schedutils/Makefile.am
index e93d31b39..81a734e96 100644
--- a/schedutils/Makefile.am
+++ b/schedutils/Makefile.am
@@ -2,8 +2,15 @@ include $(top_srcdir)/config/include-Makefile.am
if BUILD_SCHEDUTILS
-usrbinexec_PROGRAMS = chrt ionice
-man_MANS = chrt.1 ionice.1
+usrbinexec_PROGRAMS = chrt
+man_MANS = chrt.1
+
+if HAVE_IOPRIO_GET
+if HAVE_IOPRIO_SET
+usrbinexec_PROGRAMS += ionice
+man_MANS += ionice.1
+endif
+endif
if HAVE_SCHED_GETAFFINITY
usrbinexec_PROGRAMS += taskset