summaryrefslogtreecommitdiffstats
path: root/term-utils/Makefile.am
diff options
context:
space:
mode:
authorSami Kerola2011-06-12 00:19:45 +0200
committerSami Kerola2011-06-25 13:54:31 +0200
commit4aa9d65bfa76afd0d886ca410ae83428a490d4ea (patch)
tree2e99524304783636dd901bf2e27eafc6c880f176 /term-utils/Makefile.am
parentmisc-utils: remove misleading README files (diff)
downloadkernel-qcow2-util-linux-4aa9d65bfa76afd0d886ca410ae83428a490d4ea.tar.gz
kernel-qcow2-util-linux-4aa9d65bfa76afd0d886ca410ae83428a490d4ea.tar.xz
kernel-qcow2-util-linux-4aa9d65bfa76afd0d886ca410ae83428a490d4ea.zip
build-sys: move write to term-utils directory
Signed-off-by: Sami Kerola <kerolasa@iki.fi>
Diffstat (limited to 'term-utils/Makefile.am')
-rw-r--r--term-utils/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/term-utils/Makefile.am b/term-utils/Makefile.am
index c40d9db86..5e03560f1 100644
--- a/term-utils/Makefile.am
+++ b/term-utils/Makefile.am
@@ -55,12 +55,20 @@ if BUILD_WALL
usrbin_exec_PROGRAMS += wall
wall_SOURCES = wall.c ttymsg.c ttymsg.h $(top_srcdir)/lib/strutils.c
dist_man_MANS += wall.1
+endif
+
+if BUILD_WRITE
+usrbin_exec_PROGRAMS += write
+dist_man_MANS += write.1
+write_CFLAGS = $(SUID_CFLAGS) $(AM_CFLAGS)
+write_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
+endif
if USE_TTY_GROUP
if MAKEINSTALL_DO_CHOWN
install-exec-hook::
- chgrp tty $(DESTDIR)$(usrbin_execdir)/wall
- chmod g+s $(DESTDIR)$(usrbin_execdir)/wall
-endif
+ chgrp tty $(DESTDIR)$(usrbin_execdir)/wall $(DESTDIR)$(usrbin_execdir)/write
+ chmod g+s $(DESTDIR)$(usrbin_execdir)/wall $(DESTDIR)$(usrbin_execdir)/write
+
endif
endif