summaryrefslogtreecommitdiffstats
path: root/term-utils/Makefile.am
diff options
context:
space:
mode:
authorMarc-Antoine Perennou2011-06-30 02:26:32 +0200
committerKarel Zak2011-07-11 11:53:44 +0200
commit73ae0d5be6e070afe83d1a2324ac79941629201e (patch)
treee28e14ac99816e6e042da0dc7f221a535d6d24ea /term-utils/Makefile.am
parentMerge branch 'blockdev' of https://github.com/kerolasa/lelux-utiliteetit (diff)
downloadkernel-qcow2-util-linux-73ae0d5be6e070afe83d1a2324ac79941629201e.tar.gz
kernel-qcow2-util-linux-73ae0d5be6e070afe83d1a2324ac79941629201e.tar.xz
kernel-qcow2-util-linux-73ae0d5be6e070afe83d1a2324ac79941629201e.zip
build-sys: don't try to chgrp write or wall if they are not built
Fix regression from commit 4aa9d65bfa76afd0d886ca410ae83428a490d4ea Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'term-utils/Makefile.am')
-rw-r--r--term-utils/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/term-utils/Makefile.am b/term-utils/Makefile.am
index 5e03560f1..50138980f 100644
--- a/term-utils/Makefile.am
+++ b/term-utils/Makefile.am
@@ -67,8 +67,13 @@ endif
if USE_TTY_GROUP
if MAKEINSTALL_DO_CHOWN
install-exec-hook::
- chgrp tty $(DESTDIR)$(usrbin_execdir)/wall $(DESTDIR)$(usrbin_execdir)/write
- chmod g+s $(DESTDIR)$(usrbin_execdir)/wall $(DESTDIR)$(usrbin_execdir)/write
-
+if BUILD_WALL
+ chgrp tty $(DESTDIR)$(usrbin_execdir)/wall
+ chmod g+s $(DESTDIR)$(usrbin_execdir)/wall
+endif
+if BUILD_WRITE
+ chgrp tty $(DESTDIR)$(usrbin_execdir)/write
+ chmod g+s $(DESTDIR)$(usrbin_execdir)/write
+endif
endif
endif