summaryrefslogtreecommitdiffstats
path: root/term-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2011-03-02 14:06:23 +0100
committerKarel Zak2011-03-02 14:06:23 +0100
commitc76d33baccc67b3719403c1b5220d5d57ec9e950 (patch)
tree1815be3f863d3daa89a5b15ddcc00b6e6b778436 /term-utils/Makefile.am
parentbuild-sys: move setterm to term-utils/ (diff)
downloadkernel-qcow2-util-linux-c76d33baccc67b3719403c1b5220d5d57ec9e950.tar.gz
kernel-qcow2-util-linux-c76d33baccc67b3719403c1b5220d5d57ec9e950.tar.xz
kernel-qcow2-util-linux-c76d33baccc67b3719403c1b5220d5d57ec9e950.zip
build-sys: move script and scriptreplay to term-utils/
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'term-utils/Makefile.am')
-rw-r--r--term-utils/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/term-utils/Makefile.am b/term-utils/Makefile.am
index 94d377b79..62342d832 100644
--- a/term-utils/Makefile.am
+++ b/term-utils/Makefile.am
@@ -1,13 +1,24 @@
include $(top_srcdir)/config/include-Makefile.am
bin_PROGRAMS =
-usrbin_exec_PROGRAMS =
+usrbin_exec_PROGRAMS = script scriptreplay
sbin_PROGRAMS =
usrsbin_exec_PROGRAMS =
-dist_man_MANS =
+
+dist_man_MANS = script.1 scriptreplay.1
EXTRA_DIST = README.modems-with-agetty
+script_LDADD =
+
+if HAVE_UTIL
+script_LDADD += -lutil
+endif
+
+if HAVE_UTEMPTER
+script_LDADD += -lutempter
+endif
+
if BUILD_AGETTY
sbin_PROGRAMS += agetty
dist_man_MANS += agetty.8