summaryrefslogtreecommitdiffstats
path: root/term-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2011-03-02 14:20:33 +0100
committerKarel Zak2011-03-02 14:20:33 +0100
commitdb6772a19c7a5f517a36866f0aa4a92e735f96a8 (patch)
treeebce7af802a1a0d56890a0571a19682a387bfbdb /term-utils/Makefile.am
parentbuild-sys: move mesg to term-utils/ (diff)
downloadkernel-qcow2-util-linux-db6772a19c7a5f517a36866f0aa4a92e735f96a8.tar.gz
kernel-qcow2-util-linux-db6772a19c7a5f517a36866f0aa4a92e735f96a8.tar.xz
kernel-qcow2-util-linux-db6772a19c7a5f517a36866f0aa4a92e735f96a8.zip
build-sys: move wall to term-utils/
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'term-utils/Makefile.am')
-rw-r--r--term-utils/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/term-utils/Makefile.am b/term-utils/Makefile.am
index c14c1489a..26f924401 100644
--- a/term-utils/Makefile.am
+++ b/term-utils/Makefile.am
@@ -50,3 +50,17 @@ if BUILD_MESG
usrbin_exec_PROGRAMS += mesg
dist_man_MANS += mesg.1
endif
+
+if BUILD_WALL
+usrbin_exec_PROGRAMS += wall
+wall_SOURCES = wall.c ttymsg.c ttymsg.h
+dist_man_MANS += wall.1
+
+if USE_TTY_GROUP
+if MAKEINSTALL_DO_CHOWN
+install-exec-hook::
+ chgrp tty $(DESTDIR)$(usrbin_execdir)/wall
+ chmod g+s $(DESTDIR)$(usrbin_execdir)/wall
+endif
+endif
+endif