summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cbcda46c8..95ff8b3d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -430,6 +430,7 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
[AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <stdio.h>
+ #include <unistd.h>
#ifdef __GLIBC__
@@ -437,8 +438,13 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
#error %m is not available
#endif
- #else
+ #elif defined(_POSIX_VERSION)
+ #if _POSIX_VERSION < 200809L
+ #error %m is not available
+ #endif
+
+ #else
#error Your C-library is not supported.
#endif
])],