summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Schneider2014-05-08 11:52:49 +0200
committerManuel Schneider2014-05-08 11:52:49 +0200
commite13be9fc8451fea863f241e2d92c37af50573203 (patch)
tree898ce816cccbafcd82c59c93e16d0641b5bcd068 /CMakeLists.txt
parentForce connectionWindow to be always on top (diff)
downloadpvs2-e13be9fc8451fea863f241e2d92c37af50573203.tar.gz
pvs2-e13be9fc8451fea863f241e2d92c37af50573203.tar.xz
pvs2-e13be9fc8451fea863f241e2d92c37af50573203.zip
Sinec c++11 is enabled by default, set flag to stop annoying warnings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b7c408..d5164f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,8 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0)
SET(CMAKE_BUILD_TYPE Debug)
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
-SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall")
-SET(CMAKE_CXX_FLAGS_RELEASE "-O2" )
+SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -std=c++11")
+SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -std=c++11" )
# local cmake modules
SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)