summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2016-11-15 12:13:40 +0100
committerSimon Rettberg2016-11-15 12:13:40 +0100
commiteaebc23452813a8709d2bbb4d17fddb1b4f29d91 (patch)
tree956155fc2fc5b58498a4c494cc59b7adc68bc76a /CMakeLists.txt
parent[server] Rewrite positioning logic of connection frames (diff)
downloadpvs2-eaebc23452813a8709d2bbb4d17fddb1b4f29d91.tar.gz
pvs2-eaebc23452813a8709d2bbb4d17fddb1b4f29d91.tar.xz
pvs2-eaebc23452813a8709d2bbb4d17fddb1b4f29d91.zip
Increase compiler warnings, fix a lot of those instances
- Add explicit casts - Comment out unused params - Remove ignored const return types
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1cb8cb3..af61455 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,8 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0)
SET(CMAKE_BUILD_TYPE Debug)
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wunused -Wunreachable-code -pedantic")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
-SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -std=c++0x")
+SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wextra -Wpedantic -std=c++0x -Wcast-align -Wcast-qual -Wchar-subscripts -Wcomment -Wconversion -Wdisabled-optimization -Wfloat-equal -Wformat -Wformat=2 -Wformat-nonliteral -Wformat-security -Wformat-y2k -Wimport -Winit-self -Winline -Winvalid-pch -Wunsafe-loop-optimizations -Wlong-long -Wmissing-braces -Wmissing-field-initializers -Wmissing-format-attribute -Wmissing-include-dirs -Wmissing-noreturn -Wpacked -Wparentheses -Wpointer-arith -Wredundant-decls -Wreturn-type -Wsequence-point -Wsign-compare -Wstack-protector -Wstrict-aliasing -Wstrict-aliasing=2 -Wswitch -Wswitch-default -Wswitch-enum -Wtrigraphs -Wuninitialized -Wunknown-pragmas -Wunreachable-code -Wunused -Wunused-function -Wunused-label -Wunused-parameter -Wunused-value -Wunused-variable -Wvariadic-macros -Wvolatile-register-var -Wwrite-strings")
+# -Wshadow spams too much :/
SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -std=c++0x" )
# local cmake modules