summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-06-06 11:48:47 +0200
committerPaolo Bonzini2022-06-15 11:12:32 +0200
commit12640f05eb3117776162545864275949d722350f (patch)
tree23aa2c6fac31f1d233dfcb09144cbb62d52aa551 /meson.build
parentq35:Enable TSEG only when G_SMRAME and TSEG_EN both enabled (diff)
downloadqemu-12640f05eb3117776162545864275949d722350f.tar.gz
qemu-12640f05eb3117776162545864275949d722350f.tar.xz
qemu-12640f05eb3117776162545864275949d722350f.zip
meson: put cross compiler info in a separate section
While at it, remove a dead assignment and simply inline the value of the "target" variable, which is used just once. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 9 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index fe5d6632fb..0458b69cdf 100644
--- a/meson.build
+++ b/meson.build
@@ -3744,21 +3744,24 @@ endif
summary_info += {'strip binaries': get_option('strip')}
summary_info += {'sparse': sparse}
summary_info += {'mingw32 support': targetos == 'windows'}
+summary(summary_info, bool_yn: true, section: 'Compilation')
# snarf the cross-compilation information for tests
+summary_info = {}
+have_cross = false
foreach target: target_dirs
tcg_mak = meson.current_build_dir() / 'tests/tcg' / 'config-' + target + '.mak'
if fs.exists(tcg_mak)
config_cross_tcg = keyval.load(tcg_mak)
- target = config_cross_tcg['TARGET_NAME']
- compiler = ''
if 'CC' in config_cross_tcg
- summary_info += {target + ' tests': config_cross_tcg['CC']}
+ summary_info += {config_cross_tcg['TARGET_NAME']: config_cross_tcg['CC']}
+ have_cross = true
endif
- endif
+ endif
endforeach
-
-summary(summary_info, bool_yn: true, section: 'Compilation')
+if have_cross
+ summary(summary_info, bool_yn: true, section: 'Cross compilers')
+endif
# Targets and accelerators
summary_info = {}