summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2022-06-03 18:42:49 +0200
committerThomas Huth2022-07-05 10:15:49 +0200
commit2116650254117a873ab316038803cef657ae2820 (patch)
tree131f687eb9b5b8b4f586b40eb5ed9bc2a31c2e41 /meson.build
parenttests: use consistent bandwidth/downtime limits in migration tests (diff)
downloadqemu-2116650254117a873ab316038803cef657ae2820.tar.gz
qemu-2116650254117a873ab316038803cef657ae2820.tar.xz
qemu-2116650254117a873ab316038803cef657ae2820.zip
disas: Remove libvixl disassembler
The disassembly via capstone should be superiour to our old vixl sources nowadays, so let's finally cut this old disassembler out of the QEMU source tree. Message-Id: <20220603164249.112459-1-thuth@redhat.com> Tested-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 65a885ea69..f34ae9a5f8 100644
--- a/meson.build
+++ b/meson.build
@@ -250,7 +250,6 @@ endif
add_project_arguments('-iquote', '.',
'-iquote', meson.current_source_dir(),
'-iquote', meson.current_source_dir() / 'include',
- '-iquote', meson.current_source_dir() / 'disas/libvixl',
language: ['c', 'cpp', 'objc'])
link_language = meson.get_external_property('link_language', 'cpp')
@@ -2372,7 +2371,6 @@ config_target_mak = {}
disassemblers = {
'alpha' : ['CONFIG_ALPHA_DIS'],
- 'arm' : ['CONFIG_ARM_DIS'],
'avr' : ['CONFIG_AVR_DIS'],
'cris' : ['CONFIG_CRIS_DIS'],
'hexagon' : ['CONFIG_HEXAGON_DIS'],
@@ -2395,8 +2393,6 @@ disassemblers = {
}
if link_language == 'cpp'
disassemblers += {
- 'aarch64' : [ 'CONFIG_ARM_A64_DIS'],
- 'arm' : [ 'CONFIG_ARM_DIS', 'CONFIG_ARM_A64_DIS'],
'mips' : [ 'CONFIG_MIPS_DIS', 'CONFIG_NANOMIPS_DIS'],
}
endif