summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2022-02-01 09:55:21 +0100
committerPaolo Bonzini2022-02-21 10:35:54 +0100
commit23011f44d79aa982b9dbb21ffabadf0fa89066bd (patch)
tree82c8565539bf9d25c46da4b6e578fa5b5552ac4f /meson.build
parentmeson: do not make qga/vss-win32/meson.build conditional on C++ presence (diff)
downloadqemu-23011f44d79aa982b9dbb21ffabadf0fa89066bd.tar.gz
qemu-23011f44d79aa982b9dbb21ffabadf0fa89066bd.tar.xz
qemu-23011f44d79aa982b9dbb21ffabadf0fa89066bd.zip
qga/vss-win32: require widl/midl, remove pre-built TLB file
There are no good reason anymore to keep a pre-built file in the repository. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Konstantin Kostiuk <kkostiuk@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2818b93d32..8d9898c5c3 100644
--- a/meson.build
+++ b/meson.build
@@ -307,8 +307,12 @@ iokit = []
emulator_link_args = []
nvmm =not_found
hvf = not_found
+midl = not_found
+widl = not_found
host_dsosuf = '.so'
if targetos == 'windows'
+ midl = find_program('midl', required: false)
+ widl = find_program('widl', required: false)
socket = cc.find_library('ws2_32')
winmm = cc.find_library('winmm')