summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2022-02-15 17:25:03 +0100
committerPhilippe Mathieu-Daudé2022-03-15 13:36:33 +0100
commit30cfa50da53f60283e2e7f3bf0856189a06bb952 (patch)
tree61da7d0ca3bfe8ed2a833ec62e31b04cd0dadbb7 /meson.build
parentosdep: Avoid using Clang-specific __builtin_available() (diff)
downloadqemu-30cfa50da53f60283e2e7f3bf0856189a06bb952.tar.gz
qemu-30cfa50da53f60283e2e7f3bf0856189a06bb952.tar.xz
qemu-30cfa50da53f60283e2e7f3bf0856189a06bb952.zip
meson: Resolve the entitlement.sh script once for good
Commit 235b523dba ("meson: Use find_program() to resolve the entitlement.sh script") didn't correctly fixed the issue, as the script is still resolved for each target. Move the check earlier, before processing each target. Reviewed-by: Akihiko Odaki <akihiko.odaki@gmail.com> Tested-by: Akihiko Odaki <akihiko.odaki@gmail.com> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 351f9f4360..6e8fa4ab31 100644
--- a/meson.build
+++ b/meson.build
@@ -3073,6 +3073,10 @@ common_all = static_library('common',
feature_to_c = find_program('scripts/feature_to_c.sh')
+if targetos == 'darwin'
+ entitlement = find_program('scripts/entitlement.sh')
+endif
+
emulators = {}
foreach target : target_dirs
config_target = config_target_mak[target]
@@ -3230,7 +3234,6 @@ foreach target : target_dirs
install_input += meson.current_source_dir() / entitlements
endif
- entitlement = find_program('scripts/entitlement.sh')
emulators += {exe['name'] : custom_target(exe['name'],
input: build_input,
output: exe['name'],