summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-09-03 14:59:33 +0200
committerPaolo Bonzini2020-08-21 12:30:22 +0200
commit708eab42dc75304473f23ea1ead06d579dcb7566 (patch)
tree9e5afcc394ccfdc4deafdcfab9cacee795af983f /meson.build
parentmeson: convert trace/ (diff)
downloadqemu-708eab42dc75304473f23ea1ead06d579dcb7566.tar.gz
qemu-708eab42dc75304473f23ea1ead06d579dcb7566.tar.xz
qemu-708eab42dc75304473f23ea1ead06d579dcb7566.zip
meson: convert dump/
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 442855daef..6d5eb31dcf 100644
--- a/meson.build
+++ b/meson.build
@@ -300,6 +300,14 @@ if 'CONFIG_FDT' in config_host
fdt = declare_dependency(compile_args: config_host['FDT_CFLAGS'].split(),
link_args: config_host['FDT_LIBS'].split())
endif
+snappy = not_found
+if 'CONFIG_SNAPPY' in config_host
+ snappy = declare_dependency(link_args: config_host['SNAPPY_LIBS'].split())
+endif
+lzo = not_found
+if 'CONFIG_LZO' in config_host
+ lzo = declare_dependency(link_args: config_host['LZO_LIBS'].split())
+endif
create_config = find_program('scripts/create_config')
minikconf = find_program('scripts/minikconf.py')
@@ -607,6 +615,7 @@ subdir('io')
subdir('chardev')
subdir('fsdev')
subdir('target')
+subdir('dump')
block_ss.add(files(
'block.c',