summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-11-20 08:38:22 +0100
committerPaolo Bonzini2021-01-06 10:21:20 +0100
commit7bc3ca7fc03fdec3173a049c56bf6382f9007e9f (patch)
tree541566b5ba4b8ac4b1cd9b1aea7b20bfc2d8cced /meson.build
parentlibattr: convert to meson (diff)
downloadqemu-7bc3ca7fc03fdec3173a049c56bf6382f9007e9f.tar.gz
qemu-7bc3ca7fc03fdec3173a049c56bf6382f9007e9f.tar.xz
qemu-7bc3ca7fc03fdec3173a049c56bf6382f9007e9f.zip
meson.build: convert --with-default-devices to meson
Pass the boolean option directly instead of writing CONFIG_MINIKCONF_MODE to config-host.mak. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ea2a2a97a6..dd618907c0 100644
--- a/meson.build
+++ b/meson.build
@@ -1284,7 +1284,8 @@ foreach target : target_dirs
output: config_devices_mak,
depfile: config_devices_mak + '.d',
capture: true,
- command: [minikconf, config_host['CONFIG_MINIKCONF_MODE'],
+ command: [minikconf,
+ get_option('default_devices') ? '--defconfig' : '--allnoconfig',
config_devices_mak, '@DEPFILE@', '@INPUT@',
host_kconfig, accel_kconfig])
@@ -2478,7 +2479,7 @@ summary_info += {'capstone': capstone_opt == 'disabled' ? false : capst
summary_info += {'libpmem support': config_host.has_key('CONFIG_LIBPMEM')}
summary_info += {'libdaxctl support': config_host.has_key('CONFIG_LIBDAXCTL')}
summary_info += {'libudev': libudev.found()}
-summary_info += {'default devices': config_host['CONFIG_MINIKCONF_MODE'] == '--defconfig'}
+summary_info += {'default devices': get_option('default_devices')}
summary_info += {'plugin support': config_host.has_key('CONFIG_PLUGIN')}
summary_info += {'fuzzing support': config_host.has_key('CONFIG_FUZZ')}
if config_host.has_key('HAVE_GDB_BIN')