summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2022-02-22 20:40:02 +0100
committerPaolo Bonzini2022-03-15 11:26:20 +0100
commit872b69e6902f242b651a3cd0ad41bacfa574bdb6 (patch)
treec689712218ac996a621eb24c045c46c6b0f5c35e /meson.build
parentmeson: fix generic location of vss headers (diff)
downloadqemu-872b69e6902f242b651a3cd0ad41bacfa574bdb6.tar.gz
qemu-872b69e6902f242b651a3cd0ad41bacfa574bdb6.tar.xz
qemu-872b69e6902f242b651a3cd0ad41bacfa574bdb6.zip
qga/vss-win32: check old VSS SDK headers
The VssCoordinator & VssAdmin interfaces have been moved to vsadmin.h in the Windows SDK. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20220222194008.610377-3-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 80c48e43f0..ad4327888f 100644
--- a/meson.build
+++ b/meson.build
@@ -1954,12 +1954,15 @@ config_host_data.set('CONFIG_AF_VSOCK', cc.compiles(gnu_source_prefix + '''
}'''))
have_vss = false
+have_vss_sdk = false # old xp/2003 SDK
if targetos == 'windows' and link_language == 'cpp'
have_vss = cxx.compiles('''
#define __MIDL_user_allocate_free_DEFINED__
#include <vss.h>
int main(void) { return VSS_CTX_BACKUP; }''')
+ have_vss_sdk = cxx.has_header('vscoordint.h')
endif
+config_host_data.set('HAVE_VSS_SDK', have_vss_sdk)
have_ntddscsi = false
if targetos == 'windows'