summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-04-20 17:33:54 +0200
committerPaolo Bonzini2022-05-07 07:46:58 +0200
commitb0b4323e3219810d14f36c159e67a8332a86f9fd (patch)
tree54c41a5e9a932469ccead443b8ce9d5108495289 /meson.build
parentmeson, configure: move bdrv whitelists to meson (diff)
downloadqemu-b0b4323e3219810d14f36c159e67a8332a86f9fd.tar.gz
qemu-b0b4323e3219810d14f36c159e67a8332a86f9fd.tar.xz
qemu-b0b4323e3219810d14f36c159e67a8332a86f9fd.zip
meson, configure: move --with-pkgversion, CONFIG_STAMP to meson
The hash is now generated with a Python script. Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3604a0d264..4ddc72f070 100644
--- a/meson.build
+++ b/meson.build
@@ -1628,6 +1628,14 @@ config_host_data.set_quoted('CONFIG_QEMU_LOCALSTATEDIR', get_option('prefix') /
config_host_data.set_quoted('CONFIG_QEMU_MODDIR', get_option('prefix') / qemu_moddir)
config_host_data.set_quoted('CONFIG_SYSCONFDIR', get_option('prefix') / get_option('sysconfdir'))
+if config_host.has_key('CONFIG_MODULES')
+ config_host_data.set('CONFIG_STAMP', run_command(
+ meson.current_source_dir() / 'scripts/qemu-stamp.py',
+ meson.project_version(), get_option('pkgversion'), '--',
+ meson.current_source_dir() / 'configure',
+ capture: true, check: true).stdout().strip())
+endif
+
have_slirp_smbd = get_option('slirp_smbd') \
.require(targetos != 'windows', error_message: 'Host smbd not supported on this platform.') \
.allowed()
@@ -2799,7 +2807,7 @@ tracetool_depends = files(
qemu_version_cmd = [find_program('scripts/qemu-version.sh'),
meson.current_source_dir(),
- config_host['PKGVERSION'], meson.project_version()]
+ get_option('pkgversion'), meson.project_version()]
qemu_version = custom_target('qemu-version.h',
output: 'qemu-version.h',
command: qemu_version_cmd,