summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorBruce Rogers2020-08-24 17:52:12 +0200
committerPaolo Bonzini2020-08-27 18:52:30 +0200
commitc7c91a749b33412fe2a0a973799b6c44a3f73613 (patch)
treed7cbc71c37acab99a7c2d30314d51289a9c9100a /meson.build
parentscripts/qemu-version.sh: Add missing space before ']' (diff)
downloadqemu-c7c91a749b33412fe2a0a973799b6c44a3f73613.tar.gz
qemu-c7c91a749b33412fe2a0a973799b6c44a3f73613.tar.xz
qemu-c7c91a749b33412fe2a0a973799b6c44a3f73613.zip
meson: Fix meson build with --enable-libdaxctl
The daxctl library needs to be linked against when daxctl is asked for in configure. Signed-off-by: Bruce Rogers <brogers@suse.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 38d0abc0ea..b44901dfe1 100644
--- a/meson.build
+++ b/meson.build
@@ -380,6 +380,10 @@ if 'CONFIG_LIBPMEM' in config_host
libpmem = declare_dependency(compile_args: config_host['LIBPMEM_CFLAGS'].split(),
link_args: config_host['LIBPMEM_LIBS'].split())
endif
+libdaxctl = not_found
+if 'CONFIG_LIBDAXCTL' in config_host
+ libdaxctl = declare_dependency(link_args: config_host['LIBDAXCTL_LIBS'].split())
+endif
# Create config-host.h
@@ -787,7 +791,7 @@ common_ss.add(files('cpus-common.c'))
subdir('softmmu')
-specific_ss.add(files('disas.c', 'exec.c', 'gdbstub.c'), capstone, libpmem)
+specific_ss.add(files('disas.c', 'exec.c', 'gdbstub.c'), capstone, libpmem, libdaxctl)
specific_ss.add(files('exec-vary.c'))
specific_ss.add(when: 'CONFIG_TCG', if_true: files(
'fpu/softfloat.c',