summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-09 23:47:45 +0200
committerPaolo Bonzini2020-08-21 12:30:11 +0200
commitcfad62f1fa019b7c921112ae7c1e4c6fbf087929 (patch)
tree909b9df0b33e30af649b543e7d3a89ef2b7940e5 /meson.build
parentmeson: add macos dependencies (diff)
downloadqemu-cfad62f1fa019b7c921112ae7c1e4c6fbf087929.tar.gz
qemu-cfad62f1fa019b7c921112ae7c1e4c6fbf087929.tar.xz
qemu-cfad62f1fa019b7c921112ae7c1e4c6fbf087929.zip
meson: add solaris and Haiku libraries
There is no probing in configure, so no need to pass them as variables to meson. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d9758629cc..8d764a9431 100644
--- a/meson.build
+++ b/meson.build
@@ -66,6 +66,14 @@ elif targetos == 'darwin'
iokit = dependency('appleframeworks', modules: 'IOKit')
cocoa = dependency('appleframeworks', modules: 'Cocoa')
hvf = dependency('appleframeworks', modules: 'Hypervisor')
+elif targetos == 'sunos'
+ socket = [cc.find_library('socket'),
+ cc.find_library('nsl'),
+ cc.find_library('resolv')]
+elif targetos == 'haiku'
+ socket = [cc.find_library('posix_error_mapper'),
+ cc.find_library('network'),
+ cc.find_library('bsd')]
endif
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
link_args: config_host['GLIB_LIBS'].split())