summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-07-28 08:41:28 +0200
committerPaolo Bonzini2022-07-28 13:08:29 +0200
commitd82b11f69953cf15cee819bcf02dfd87325980a9 (patch)
tree3581052adce068d86ce7b15caf44823cda39e50c /meson.build
parentUpdate version for v7.1.0-rc0 release (diff)
downloadqemu-d82b11f69953cf15cee819bcf02dfd87325980a9.tar.gz
qemu-d82b11f69953cf15cee819bcf02dfd87325980a9.tar.xz
qemu-d82b11f69953cf15cee819bcf02dfd87325980a9.zip
ui: dbus-display requires CONFIG_GBM
Without CONFIG_GBM, compiling dbus-display fails with ../ui/dbus.c: In function ‘dbus_create_context’: ../ui/dbus.c:47:20: error: ‘qemu_egl_rn_ctx’ undeclared (first use in this function); did you mean ‘qemu_egl_init_ctx’? 47 | qemu_egl_rn_ctx); | ^~~~~~~~~~~~~~~ | qemu_egl_init_ctx ../ui/dbus.c:47:20: note: each undeclared identifier is reported only once for each function it appears in and many other similar errors, because include/ui/egl-helpers.h only has these declaration if gbm is found on the system. Resolves: https://gitlab.com/qemu-project/qemu/-/issues/1108 Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 75aaca8462..294e9a8f32 100644
--- a/meson.build
+++ b/meson.build
@@ -1677,8 +1677,8 @@ dbus_display = get_option('dbus_display') \
error_message: '-display dbus requires --enable-modules') \
.require(gdbus_codegen.found(),
error_message: '-display dbus requires gdbus-codegen') \
- .require(opengl.found(),
- error_message: '-display dbus requires epoxy/egl') \
+ .require(opengl.found() and gbm.found(),
+ error_message: '-display dbus requires epoxy/egl and gbm') \
.allowed()
have_virtfs = get_option('virtfs') \