summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2021-10-09 15:37:40 +0200
committerMarc-André Lureau2021-12-21 07:50:22 +0100
commitd83acfd013ada96f3c5fe216f8b3648f0d311a4c (patch)
tree6f4712b4418e7c65eed44200e0d8e61e8cdd8666 /meson.build
parentdocs: add dbus-display documentation (diff)
downloadqemu-d83acfd013ada96f3c5fe216f8b3648f0d311a4c.tar.gz
qemu-d83acfd013ada96f3c5fe216f8b3648f0d311a4c.tar.xz
qemu-d83acfd013ada96f3c5fe216f8b3648f0d311a4c.zip
build-sys: set glib dependency version
Further meson configuration tests are to be added based on the glib version. Also correct the version reporting in the config log. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Acked-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1c70839bbf..c37eb92ebe 100644
--- a/meson.build
+++ b/meson.build
@@ -404,14 +404,16 @@ endif
add_project_arguments(config_host['GLIB_CFLAGS'].split(),
native: false, language: ['c', 'cpp', 'objc'])
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
- link_args: config_host['GLIB_LIBS'].split())
+ link_args: config_host['GLIB_LIBS'].split(),
+ version: config_host['GLIB_VERSION'])
# override glib dep with the configure results (for subprojects)
meson.override_dependency('glib-2.0', glib)
gio = not_found
if 'CONFIG_GIO' in config_host
gio = declare_dependency(compile_args: config_host['GIO_CFLAGS'].split(),
- link_args: config_host['GIO_LIBS'].split())
+ link_args: config_host['GIO_LIBS'].split(),
+ version: config_host['GLIB_VERSION'])
endif
lttng = not_found
if 'ust' in get_option('trace_backends')