summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-09-23 12:55:28 +0200
committerPaolo Bonzini2021-09-30 15:30:24 +0200
commite49c0ef6f1cca3943f3d61da6e3da7e03ddf2a22 (patch)
treef11e97ebadb97bc9667207231487f7560cca88ae /meson.build
parenttarget/i386: Add the query-sgx-capabilities QMP command (diff)
downloadqemu-e49c0ef6f1cca3943f3d61da6e3da7e03ddf2a22.tar.gz
qemu-e49c0ef6f1cca3943f3d61da6e3da7e03ddf2a22.tar.xz
qemu-e49c0ef6f1cca3943f3d61da6e3da7e03ddf2a22.zip
meson: unpack edk2 firmware even if --disable-blobs
The edk2 firmware blobs are needed to run bios-tables-test. Unpack them if any UEFI-enabled target is selected, so that the test can run. This is a bit more than is actually necessary, since bios-tables-test does not run for all UEFI-enabled targets, but it is the easiest way to write this logic. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com> Message-Id: <20210923105529.3845741-1-pbonzini@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 7bdbbbdf02..fbdab3063b 100644
--- a/meson.build
+++ b/meson.build
@@ -106,14 +106,14 @@ if targetos != 'darwin'
endif
edk2_targets = [ 'arm-softmmu', 'aarch64-softmmu', 'i386-softmmu', 'x86_64-softmmu' ]
-install_edk2_blobs = false
-if get_option('install_blobs')
- foreach target : target_dirs
- install_edk2_blobs = install_edk2_blobs or target in edk2_targets
- endforeach
-endif
-
-bzip2 = find_program('bzip2', required: install_edk2_blobs)
+unpack_edk2_blobs = false
+foreach target : edk2_targets
+ if target in target_dirs
+ bzip2 = find_program('bzip2', required: get_option('install_blobs'))
+ unpack_edk2_blobs = bzip2.found()
+ break
+ endif
+endforeach
##################
# Compiler flags #