summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-10-13 11:42:25 +0200
committerPaolo Bonzini2022-02-21 10:35:53 +0100
commited793c2c455e1c376ae271d8acc5ac40221ecfd1 (patch)
treee2866e688d74abc00b27957ffc1b59ec919082d5 /meson.build
parentconfigure, meson: cleanup qemu-ga libraries (diff)
downloadqemu-ed793c2c455e1c376ae271d8acc5ac40221ecfd1.tar.gz
qemu-ed793c2c455e1c376ae271d8acc5ac40221ecfd1.tar.xz
qemu-ed793c2c455e1c376ae271d8acc5ac40221ecfd1.zip
configure, meson: move image format options to meson_options.txt
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 02137be91e..38e3ea46e1 100644
--- a/meson.build
+++ b/meson.build
@@ -3463,14 +3463,14 @@ if have_block
summary_info += {'build virtiofs daemon': have_virtiofsd}
summary_info += {'Live block migration': config_host.has_key('CONFIG_LIVE_BLOCK_MIGRATION')}
summary_info += {'replication support': config_host.has_key('CONFIG_REPLICATION')}
- summary_info += {'bochs support': config_host.has_key('CONFIG_BOCHS')}
- summary_info += {'cloop support': config_host.has_key('CONFIG_CLOOP')}
- summary_info += {'dmg support': config_host.has_key('CONFIG_DMG')}
- summary_info += {'qcow v1 support': config_host.has_key('CONFIG_QCOW1')}
- summary_info += {'vdi support': config_host.has_key('CONFIG_VDI')}
- summary_info += {'vvfat support': config_host.has_key('CONFIG_VVFAT')}
- summary_info += {'qed support': config_host.has_key('CONFIG_QED')}
- summary_info += {'parallels support': config_host.has_key('CONFIG_PARALLELS')}
+ summary_info += {'bochs support': get_option('bochs').allowed()}
+ summary_info += {'cloop support': get_option('cloop').allowed()}
+ summary_info += {'dmg support': get_option('dmg').allowed()}
+ summary_info += {'qcow v1 support': get_option('qcow1').allowed()}
+ summary_info += {'vdi support': get_option('vdi').allowed()}
+ summary_info += {'vvfat support': get_option('vvfat').allowed()}
+ summary_info += {'qed support': get_option('qed').allowed()}
+ summary_info += {'parallels support': get_option('parallels').allowed()}
summary_info += {'FUSE exports': fuse}
endif
summary(summary_info, bool_yn: true, section: 'Block layer support')