summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-11-06 12:14:57 +0100
committerRichard Henderson2021-11-11 11:47:01 +0100
commitf1f727ac8a19c9106a4c92a98a3cde4b284fcef5 (patch)
tree7507ced9f5645e4ae7eb2f3786e3eb4343d8a75a /meson.build
parenttcg/optimize: Add an extra cast to fold_extract2 (diff)
downloadqemu-f1f727ac8a19c9106a4c92a98a3cde4b284fcef5.tar.gz
qemu-f1f727ac8a19c9106a4c92a98a3cde4b284fcef5.tar.xz
qemu-f1f727ac8a19c9106a4c92a98a3cde4b284fcef5.zip
tcg: Remove TCI experimental status
The following commits (released in v6.0.0) made raised the quality of the TCI backend to the other TCG architectures, thus is is not considerated experimental anymore: - c6fbea47664..2f74f45e32b - dc09f047edd..9e9acb7b348 - b6139eb0578..2fc6f16ca5e - dbcbda2cd84..5e8892db93f Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20211106111457.517546-1-f4bug@amsat.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9702fdce6d..2ece4fe088 100644
--- a/meson.build
+++ b/meson.build
@@ -335,7 +335,7 @@ tcg_arch = config_host['ARCH']
if not get_option('tcg').disabled()
if cpu not in supported_cpus
if get_option('tcg_interpreter')
- warning('Unsupported CPU @0@, will use TCG with TCI (experimental and slow)'.format(cpu))
+ warning('Unsupported CPU @0@, will use TCG with TCI (slow)'.format(cpu))
else
error('Unsupported CPU @0@, try --enable-tcg-interpreter'.format(cpu))
endif
@@ -3290,7 +3290,7 @@ endif
summary_info += {'TCG support': config_all.has_key('CONFIG_TCG')}
if config_all.has_key('CONFIG_TCG')
if get_option('tcg_interpreter')
- summary_info += {'TCG backend': 'TCI (TCG with bytecode interpreter, experimental and slow)'}
+ summary_info += {'TCG backend': 'TCI (TCG with bytecode interpreter, slow)'}
else
summary_info += {'TCG backend': 'native (@0@)'.format(cpu)}
endif