summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-01-24 13:08:01 +0100
committerPaolo Bonzini2020-08-21 12:30:39 +0200
commitf556b4a10d3ccd6cad01f704e4ccb2252520d61e (patch)
tree3d9ee5e77ee2b2b193fe9ca7f785bc268c3c8f1c /meson.build
parentmeson: cpu-emu (diff)
downloadqemu-f556b4a10d3ccd6cad01f704e4ccb2252520d61e.tar.gz
qemu-f556b4a10d3ccd6cad01f704e4ccb2252520d61e.tar.xz
qemu-f556b4a10d3ccd6cad01f704e4ccb2252520d61e.zip
meson: plugins
For now link arguments end up in Makefile.target, they will move to the right place soon. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5b1608df09..fa47410c29 100644
--- a/meson.build
+++ b/meson.build
@@ -731,6 +731,7 @@ subdir('net')
subdir('replay')
subdir('hw')
subdir('accel')
+subdir('plugins')
subdir('bsd-user')
subdir('linux-user')
@@ -899,6 +900,10 @@ endforeach
# Other build targets
+if 'CONFIG_PLUGIN' in config_host
+ install_headers('include/qemu/qemu-plugin.h')
+endif
+
if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif