summaryrefslogtreecommitdiffstats
path: root/audio/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2021-03-09 14:15:28 +0100
committerMarc-André Lureau2021-12-21 07:50:22 +0100
commit739362d4205cd90686118fe5af3e236c2f8c6be9 (patch)
tree10d27d3efc227f29ffee0dd02d345e0faa707623 /audio/meson.build
parenttests: start dbus-display-test (diff)
downloadqemu-739362d4205cd90686118fe5af3e236c2f8c6be9.tar.gz
qemu-739362d4205cd90686118fe5af3e236c2f8c6be9.tar.xz
qemu-739362d4205cd90686118fe5af3e236c2f8c6be9.zip
audio: add "dbus" audio backend
Add a new -audio backend that accepts D-Bus clients/listeners to handle playback & recording, to be exported via the -display dbus. Example usage: -audiodev dbus,in.mixing-engine=off,out.mixing-engine=off,id=dbus -display dbus,audiodev=dbus Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Acked-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'audio/meson.build')
-rw-r--r--audio/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/meson.build b/audio/meson.build
index 462533bb8c..0ac3791d0b 100644
--- a/audio/meson.build
+++ b/audio/meson.build
@@ -26,4 +26,10 @@ foreach m : [
endif
endforeach
+if dbus_display
+ module_ss = ss.source_set()
+ module_ss.add(when: gio, if_true: files('dbusaudio.c'))
+ audio_modules += {'dbus': module_ss}
+endif
+
modules += {'audio': audio_modules}